yum安装lamp环境

  • 作者:未知
  • 来源:
  • 2018-05-14 17:49:04

1、安装Apache [root@localhost ~]# yum -y install httpd # 开机自启动 [root@localhost ~]# chkconfig httpd on # 启动httpd 服务 [root@localhost ~]# service httpd start ### 安装apache 一些扩展 root@localho...

1、安装Apache

002UASMrzy7605pjKJv15&690.jpg

[root@localhost ~]# yum -y install httpd # 开机自启动 [root@localhost ~]# chkconfig httpd on # 启动httpd 服务 [root@localhost ~]# service httpd start ### 安装apache 一些扩展 root@localhost ~]# yum -y install httpd-manual mod_ssl mod_perl mod_auth_mysql 现在直接在浏览器键入http://localhost 或 http://本机IP ,应该会看到Apache的测试页面 2、安装配置MySQL

# mysql 客户端程序 # mysql-server 服务端程序 # mysql-devel 开发设计的库 [root@localhost ~]# yum -y install mysql mysql-server mysql-devel # 开机启动 [root@localhost ~]# chkconfig mysqld on # 启动mysqld服务 [root@localhost ~]# service mysqld start # 进行一些安全性配置 [root@localhost ~]# /usr/bin/mysql_secure_installation [root@localhost ~]# netstat -tulpn | grep -i mysql tcp 0 0 0.0.0.0:3306 0.0.0.0:* LISTEN 1723/mysqld

OK, 我们看到mysqld已经启动,监听在3306端口上。

3、安装php

安装相关模块:为了让PHP支持MySQL,我们可以安装php-mysql软件包;也可使用以下命令搜索可用的php模块

[root@localhost ~]# yum -y install php php-mysql # 安装php常用扩展 [root@localhost ~]# yum search php [root@localhost ~]# yum -y install gd php-gd gd-devel php-xml php-common php-mbstring php-ldap php-pear php-xmlrpc php-imap ### 重启httpd服务,这一步很重要 [root@localhost ~]# service httpd restart 然后,我们提供php页面,测试 [root@localhost ~]# cd /var/www/html/ [root@localhost html]# vi index.php <?php phpinfo(); ?>

然后,我们再次在浏览器键入http://localhost 或 http://本机IP ,应该会看到版本信息页面

使用yum安装PHP的版本是5.3比较低 安装PHP的时候可以自己进行安装较新的版本:

Centos 6.x/7.x yum安装php5.6.X(最新版)

鉴于Centos 默认yum源的php版本太低了,手动编译安装又有点一些麻烦,那么如何采用Yum安装的方案安装最新版呢。那么,今天我们就来学习下如何用yum安装php最新版。

1.检查当前安装的PHP包

yumlistinstalled|grepphp

如果有安装的PHP包,先删除他们

yumremovephp.x86_64php-cli.x86_64php-common.x86_64php-gd.x86_64php-ldap.x86_64php-mbstring.x86_64php-mcrypt.x86_64php-mysql.x86_64php-pdo.x86_64

配置yum源

追加CentOS 6.5的epel及remi源。

#rpm-Uvhhttp://ftp.iij.ad.jp/pub/linux/fedora/epel/6/x86_64/epel-release-6-8.noarch.rpm #rpm-Uvhhttp://rpms.famillecollet.com/enterprise/remi-release-6.rpm

以下是CentOS 7.0的源。

#yuminstallepel-release #rpm-ivhhttp://rpms.famillecollet.com/enterprise/remi-release-7.rpm

使用yum list命令查看可安装的包(Packege)。

#yumlist--enablerepo=remi--enablerepo=remi-php56|grepphp

安装PHP5.6.x yum源配置好了,下一步就安装PHP5.6。

#yum -y install --enablerepo=remi --enablerepo=remi-php56 php php-opcache php-devel php-mbstring php-mcrypt php-mysqlnd php-phpunit-PHPUnit php-pecl-xdebug php-pecl-xhprof php-gd php-xml php-common php-mbstring php-ldap php-pear php-xmlrpc php-imap

用PHP命令查看版本。

#php--version PHP5.6.0(cli)(built:Sep3201419:51:31) Copyright(c)1997-2014ThePHPGroup ZendEnginev2.6.0,Copyright(c)1998-2014ZendTechnologies withZendOPcachev7.0.4-dev,Copyright(c)1999-2014,byZendTechnologies withXdebugv2.2.5,Copyright(c)2002-2014,byDerickRethans

安装PHP-fpm

yuminstall--enablerepo=remi--enablerepo=remi-php56php-fpm Apache虚拟主机配置

配置虚拟主机出现的问题:

1.[Fri Nov 24 17:26:21 2017] [warn] _default_ VirtualHost overlap on port 80, the first has precedence 解决:打开httpd.conf文件 #NameVirtualHost *:80前的注释去掉 如果不去掉这个注释,则会导致虚拟主机的配置不会生效 重启Apache 2. httpd: Could not reliably determine the server's fully qualified domain name, using 10.29.79.140 for ServerName 解决:用记事本打开 httpd.conf 将里面的 #ServerName localhost:80 注释去掉即可。 没有就添加:ServerName localhost:80 3.configuration error: couldn't perform authentication. AuthType not set!: / 解决: 原因: <Directory /var/www/html> Options Indexes FollowSymLinks AllowOverride None Require all granted #属于2.4.X版本 </Directory> 修改为: <Directory "/var/www/html"> Options Indexes FollowSymLinks AllowOverride None Order allow,deny Allow from all </Directory> Vhosts.conf文件:

<VirtualHost *:80> DocumentRoot "/var/www/html/follow" ServerName follow.udeafx.com ServerAlias phpStudy.net <Directory "/var/www/html/follow"> Options Indexes FollowSymLinks AllowOverride all Order allow,deny Allow from all </Directory> </VirtualHost>

免责声明:本文内容由互联网用户自发贡献自行上传,本网站不拥有所有权,也不承认相关法律责任。如果您发现本社区中有涉嫌抄袭的内容,请发送邮件至:operations@xinnet.com进行举报,并提供相关证据,一经查实,本站将立刻删除涉嫌侵权内容。

免费咨询获取折扣